3D Window with Plan View Drape : Softree Technical Systems Support

Knowledge Base

Back to Terrain Module


3D Window with Plan View Drape

Updated November 07, 2016


This article applies to:
  • Terrain 3D
  • Terrain Forestry
  • RoadEng Civil
  • RoadEng Forestry

Please download the associated files to go with this example:

3D Window with Plan-View Drape


Terrain Tools is not a sophisticated 3D rendering program, however, it is capable of producing reasonably good 3D visualizations for public and client presentations. This example will illustrate how to 'drape' the plan window over a 3D model.

It should be noted that the quality of the 3D rendering is determined largely by the quality of the terrain model and the image.

Draping the Plan Window.

1. Open Terrain Module. Select menu File | Open and choose file FG.ter (included with this example - see top for file link).

Figure 1: FG.ter - Lidar Based Realignment

Note: FG.ter is a road realignment. The original survey was based on LiDAR. The new alignment was designed using RoadEng. From the completed design a terrain file was created and merged back into the original ground surface. The procedure to do this is described in the Creating a Post Design Surface example.

The original survey came with an aerial image which we will drape over the our 3D view to give make it more realistic.

2. Select menu File | Insert and choose All supported files in the combo box in the lower in the lower right corner. Choose M21.tif (included with this example).

Note: M21.tif has been georeferenced and should appear in the spatially correct position in the terrain file.

3. When the Import Options appears set the Image Quality to high. Press OK.

Figure 2: FG.ter - Image Import Options

The Terrain Screen should appear as shown below.

Figure 3: FG.ter with Aerial Image

4. Click on the 3D Window to make it active. Right click and choose menu Active Window (3D) Options.

Figure 4: 3D Options

5. Click on the "+" button beside Drape Plan Image to activate the Plan View Drape Options. Set the Drape Quality to the highest quality as shown in the figure below. Press OK twice.

Figure 5: Plan View Drape Options

When the 3D window re-calculation is complete, it should appear as shown below.

Figure 6: Plan Window and 3D Window with Plan View Drape

To complete this example, we will overlay some shapes on the 3D image.

6. Select menu File | Insert and choose shapes.ter (included with this example). When the import options dialog appears accept the defaults.

7. Right click in the 3D window and choose menu Update 3D Display lists. The screen should appear as shown below.

Figure 7: Plan Window and 3D Window with Image and Shapes

8. Close Terrain and do not save changes.


Top