Knowledge Base

Back to Terrain Module


Crossing Breaklines

Updated May 30, 2016


This article applies to:
  • Terrain 3D
  • Terrain Forestry
  • RoadEng Civil
  • RoadEng Forestry

Please download the associated files to go with this example:


The Terrain module uses a triangular irregular network (TIN) to represent surfaces. Breaklines can be used to represent smooth linear breaks in topography such as creeks, ditch bottoms, road shoulders and others.

Breakline elevations are defined between points (linear interpolation), thus breakline segments must be represented by triangle edges. Triangles cannot cross breaklines. Crossing breaklines (that do not share a point at the intersection) define more than one elevation at that point and are therefore inconsistent.

The following example shows how breaklines improve a model and how to find and fix crossing breaklines. Skip to the Crossing Breaklines section if you are only interested finding and removing crossing breaklines.

Breakline Behaviour

In this section we will remove the breakline properties from some features to see what affect this has on the Terrain.

1.Open file “BoundaryRoad.ter” included with this example.


Figure 1 – Plan View of Boundary Road Terrain with contours

2. Use the Window | New Window | Graphics | 3D menu to view this surface with the 3D Window (optional). Switch back to the Plan window afterward.

Figure 2 – 3D view of a portion of the surface

3.Select the features that define the road corridor (including top of cut).


Figure 3 – Selection of road corridor features (and some additional features) with the mouse.

4. Menu Edit | Modify Selected Feature(s) | Properties Ctrl-E (also available from the right click menu) pops up the dialog box below.

Figure 4 – The Breakline item is partially checked indicating that some of the selected features have this property turned on.

5.Clear the Breakline check box and press OK.

6. Re-calculate the Terrain model (menu Edit | Terrain Modeling | Calculate Terrain Model; keep the existing settings).

Figure 5 – Plan and 3D view of surface recalculated with breaklines removed.

NOTE: How the contours now spill onto the road; the original breaklines prevented triangles from crossing over the ditch and right hand road edge.

7. Do not save your changes!

NOTE: Once you have created a feature that represents a breakline, use the Features Properties dialog to set the Breakline property. Recalculate your TIN model after modifying or adding breaklines.

Crossing Breaklines

This section shows how to find and fix crossing breaklines.

1. (Re)Open file “BoundaryRoad.ter” included with this example (do not save changes if continuing from the previous section).

2. File | Insert File “Creek.ter”, also included with this example (press OK to accept the default import options). This inserts a single breakline feature called CREEK.

3. Re-calculate the Terrain model (menu Edit | Terrain Modeling | Calculate Terrain Model; keep the existing settings).

You will be presented with the following error messages

Figure 6 – This message is presented for every crossing breakline if you clear the’ Do not show me this message again’ box.

Figure 7 ­– This message is presented at the end of the triangle processing.

In this case it is clear where the crossing breaklines occur and which feature needs attention. However, in another model there may be many crossing breaklines and it may be hard to find them just by looking. The following steps will use the XBreak attribute to find crossing breaklines.

4. Use the Window | New Window | Text | Points menu to add a Points window to the panel at the right of your screen.

This window is already set up to show feature name and the XBreak attribute. You can choose which columns to display in the Points Window options dialog box (available from the right click menu).
The text windows (both Features and Points) display a list of features; you can change this list by selecting the desired features and then updating the displayed list. We will do this in the next steps.

5. Use the Edit | Select Feature(s) | By Property dialog box to select all breakline features (also available from the right click menu).

Figure 8 – Only Breakline features will be selected after pressing OK.

6. Press the display selected features button at the bottom of the Points window to update the contents of the window.

Figure 9 – Points window display selected features button.

7. Press the XBreak column heading to sort the points by this attribute. You may have to scroll and or press the column heading twice to sort with the XBreak items at the top (see figure below).

8. Select the XBreak point at the top of the list with your mouse. Points tagged with the XBreak attribute will be at one end of a crossing breakline segment.

Figure 10 – Points window sorted by XBreak. The Plan window shows the selected CREEK feature with the XBreak point highlighted.

When you click on an item in the Points window, if it is not visible, the Plan window will scroll this point to the middle of the window. Similarly, the point will be selected and set to the current point (and displayed in the status window). You may wish to experiment with this behavior by scrolling you Plan window, selecting another feature and then repeating the step above.
There are many different ways to “fix” a crossing breakline:
    • Clear the Breakline property from one of the offending features.
    • Insert a new point in one breakline feature and snap it to a point in the other. Breaklines are allowed to cross if they share a common point.
    • Remove a segment from one of the breaklines (making it into two features).
In this example the creek actually flows through a culvert under the road. We will remove this segment from the surface model.

9. Use the Edit | Modify selected Feature(s) | Break | At Current Point (Ctrl-Q) menu item to break the CREEK feature to the left of the road (the current point shown in the figure above). Reply OK to the Triangles will be cleared warning.

10. Select the first point to the right of the road (figure below) and repeat the step above the break the feature a second time.

Figure 11 – Second break point In CREEK feature.

11. Select the middle feature and display its properties (Menu Edit | Modify Selected Feature(s) | Properties Ctrl-E).

12. Clear the Modelled property (this automatically clears the Breakline property) so that this feature will not be part of the surface. Rename it as CULVERT.


Figure 12 – Middle portion of CREEK breakline isolated and renamed as CULVERT. It is no longer a breakline and will not contribute to the surface model.


13. Re-calculate the Terrain model (menu Edit | Terrain Modeling | Calculate Terrain Model; keep the existing settings).

NOTE: That there is no error messages. Also the model (as indicated by contours) is not noticeably different from the one generated when there were crossing breaklines. The software attempts to accommodate the crossing breakline inconsistency and, in this case, it did a pretty good job. However, it is not wise to ignore inconsistent triangle error messages.

14. Choose menu File | Exit. Don’t save changes.

Top