Knowledge Base

Back to Terrain Module


Exporting to HEC-RAS

Updated May 19, 2016


This article applies to:
  • Terrain 3D
  • Terrain Forestry
  • RoadEng Civil
  • RoadEng Forestry

Download the files associated with this example: Exporting to HEC-RAS.zip


HEC-RAS is a one-dimensional, steady-flow, water surface profiling program (U.S. Army Corps of Engineers, 1998). HEC-RAS requires definition of the land topography and flow information for hydrologic events. The geometric and flow data are used to calculate steady, water surface profiles based on energy loss computations. HEC-RAS can be used to model a single river reach or an entire river network.

River networks

River networks define the connectivity of the river system. A river system is a collection of reaches, all oriented downstream. A reach is defined in HEC-RAS as starting or ending at junctions - locations where two or more streams join together or split apart. A river may be composed of one or more reaches. In Terrain each reach a terrain feature.

Figure 1: River Network and Cross Sections

Cross Sections

Channel cross-section data is used in HEC-RAS to characterize the flow capacity of the river and floodplain. Cross-section data includes station-elevation coordinates, main channel bank stations, downstream and reach lengths.

Station-elevation data represent the ground surface at designated locations in a river reach. Cross sections are taken perpendicular the direction of flow both in the main channel and in the overbank areas. Bank stations separate the main channel area from the adjacent floodplain (termed the left and right overbank areas).

Reach lengths are used to define the distance between cross sections and are used for energy loss calculations in HEC-RAS. Reach lengths are considered for the left overbank, main channel, and right overbank areas and indicate the path of flow between cross sections.

The Terrain Module will calculate reach lengths and bank positions automatically from left, right and main channel features.

Figure 2: Bank positions and reach lengths

Creating a Hec-Ras File

To run this example you will need Terrain Tools® or RoadEng® Version 5.1163 or higher.

In order to do this example you will also need to have the HEC-RAS export option enabled. If you are not sure if this option is enabled, choose menu Module | Setup | Export. Examine the list to see if there is an export specification for a HEC-RAS *.geo file. If there isn’t, you will have to create a new IO specification.


Figure 3: Hec-Ras Export Specification

1. File | Open. Select Stream.ter. Press Open.

Figure 4: Stream.ter stream channel, cross sections and bank features

Notice the terrain file contains 3D features for the stream channel, cross sections and left and right banks. The left and right bank features are optional.
There are several ways to create these features. For instance, creating the cross sections can be done in Terrain using the Edit | Modify Selected | Interpolate | Sections function. Similarly, a channel can be designed in the Location module and saved in Terrain format with cross sections and bank features.

2. Choose menu File | Save As. Select the HEC-RAS (*.geo) format in the drop down list. Set the name to Stream.geo. Press OK and the HEC-RAS export options dialog will appear as shown in Figure 6.

3. Click the Add button beside Reaches and choose the CL-2 feature.

4. Enter a Reach ID and Stream ID eg. “West” and “Rainy”.

5. Click on the Select button beside Left bank, and choose the Bank_left feature.

6. Similarly click on the Select button beside Right bank, and choose the Bank_right feature.

7. Click the Add button beside Sections and select all the section features (this is easily done by holding down the Shift key) as shown in Figure 5.

Figure 5: Selecting Sections

The dialog box should now appear as shown in Figure 6: below.

Figure 6: Hec-Ras Export Options dialog

8.Pressing OK will create a HEC-RAS geo file. You are now ready to import it into HEC-RAS.

Importing the Geometry file into Hec-Ras

9.Run HEC-RAS and create a new project (File | New Project).

Figure 7: HEC-RAS: Project Creation

10.Choose menu Edit | Geometric Data. The Geometric Data dialog box will appear.


Figure 8: Geometric Data dialog box

11. Select menu File | Import Geometry Data | GIS Format. The GIS Format dialog box will appear. Choose the Stream.geo file created in previous steps.

Figure 9: Import GIS Format dialog box

12. After choosing the project units and confirming the cross sections, the Stream.geo file will be imported.

Figure 10: Imported geometry data.

You are now ready to do HEC-RAS analysis. This completes the example.

Top