Knowledge Base

Back to Terrain Module


World Image Files

Updated May 03, 2016


This article applies to:
  • Terrain 3D
  • Terrain Forestry
  • RoadEng Civil
  • RoadEng Forestry

World files are small text files that contain the size and position (georeference) information for an image. A typical world file might look like:

20.154 <the dimension of a pixel in project units in the x direction>
0.000 <rotation term for row>
0.000 <rotation term for column>
-20.154 <the dimension of a pixel in project units in the y direction>
424178 <the x coordinate of the center of pixel 1,1 (upper-left pixel)>
4313415 <the y coordinate of the center of pixel 1,1 (upper-left pixel)>

World file formats have different extensions for different image types. When an image is read (using menu File | Open or File | Insert File), Terrain looks for a matching world file using the following extensions.

*.tfw - world file for tif image
*.bpw - world file for bmp images
*.jgw - world file for jpg

If no world file exists, the image is inserted so that the upper left corner is in the center of the screen and the pixel size is set to one.

It should also be noted that GeoTiff files are Tif images with georeference information embedded in them. Terrain will read GeoTiff files. GeoTiff files (such as USGS DRG’s) strictly do not require a world file because they already have that information embedded in the file. In this case if a world file exists, the information in the world file will override the embedded information.

In this brief example we will read an image, georeference it (shift and scale) then save the georeferenced information to a world file.

  1. Start up the Terrain module and select menu File | Open. Select Image files (*.tif, *.jpg, *.bmp). Choose the name of the image you wish to insert.
  2. After pressing OK in the File | Open dialog, the Image Properties dialog will appear. Set the Reference Coordinate to a suitable coordinate such as UTM or State Plane. Set the Pixel size in project units and press OK.
  3. When the image appears it will be positioned and sized according to the parameters in the previous step. We will now save these parameters in a World File. Saving the World file will allow other software such as ArcView to read the image in the correct location.
  4. With the image selected choose menu Edit | Modify Selected Features | Properties. In the World File group choose Save. This will create a world file in the same directory as the image.
Top